USAC - Vendor System - Intermittent Errors

Incident Report for Lifeline System

Resolved

USAC confirmed the issue is resolved and apologized for the inconvenience.
Posted Sep 23, 2025 - 10:52 EDT

Investigating

We wanted to pass along the following notice from USAC:

USAC is aware that users are experiencing intermittent issues performing transactions in the National Verifier and National Verifier Carrier API that began around 7:15 a.m. ET. USAC is actively working on a resolution
Posted Sep 23, 2025 - 09:55 EDT
This incident affected: USAC - Vendor System (NLAD, National Verifier).