USAC - Vendor System - Increased Error Rates

Incident Report for Lifeline System

Resolved

This issue appears to be resolved. We're seeing all NLAD Verify transactions complete normally now. If we start to see further issues, we will send a new notice.
Posted Apr 25, 2025 - 18:16 EDT

Update

USAC expects to resolve the issue after 6pm EST today. We'll continue monitoring and pass along any additional info from their team.
Posted Apr 25, 2025 - 15:22 EDT

Identified

We're currently observing intermittent errors on NLAD Verify transactions which are primarily impacting ecomm enrollments. USAC has confirmed their IT team is looking into the issue. Once we have an update from their team, we will pass it along.
Posted Apr 25, 2025 - 13:52 EDT
This incident affected: USAC - Vendor System (NLAD).