USAC - Vendor System - Lifeline Mobile Application Issues

Incident Report for Lifeline System

Resolved

USAC has confirmed the issue is resolved. Please see their notice below:

"USAC is aware that consumers were unable to submit Lifeline applications using mobile devices earlier today. The issue was resolved around 12:50 p.m. ET. Consumers and service providers can now submit applications using a mobile device. We apologize for any inconvenience this may have caused."
Posted Aug 27, 2025 - 13:19 EDT

Update

There are no new or additional updates at this time. When accessing the National Verifier website through a mobile app, there is a banner that reads "We are currently having trouble accepting applications from mobile devices. You can use a desktop computer while we resolve the issue."
Posted Aug 27, 2025 - 12:18 EDT

Identified

USAC sent the following notice a short time ago:

"USAC is aware that consumers are currently unable to submit Lifeline applications using mobile devices. Consumers and service providers may continue submitting applications using a desktop computer. USAC is actively working on resolving the issue. We apologize for any inconvenience this may cause."

From the CGM side, it appears the National Verifier website is up, but users on mobile devices may have trouble navigating the page and filling out forms until the issue is resolved. If we determine other issues beyond this or receive an update from USAC, we will post an update. The NLAD API appears to be functioning normally at this time.
Posted Aug 27, 2025 - 09:31 EDT
This incident affected: USAC - Vendor System (National Verifier).