USAC - Vendor System - Increased Error Rates

Incident Report for Lifeline System

Resolved

USAC has resolved the issue and all transactions are completing normally. If we see further issues we will send a new notice.
Posted Jul 18, 2025 - 17:57 EDT

Identified

USAC provided the following update:

"Thank you for bringing this to our attention. Our teams are aware of this issue and are actively working on a resolution. As soon as we have an update, we will follow up with you. We apologize for any inconvenience this may cause."
Posted Jul 18, 2025 - 17:18 EDT

Investigating

We're currently observing increased error rates on Nlad/Nav transactions. As soon as we receive an update, we will pass it along. Please note that USAC has scheduled maintenance in 5 hours.
Posted Jul 18, 2025 - 16:38 EDT
This incident affected: USAC - Vendor System (NLAD, National Verifier).