USAC - Vendor System - Increased Error Rates

Incident Report for Lifeline System

Resolved

This issue is now resolved. If we see further issues we will open a new incident.
Posted May 21, 2025 - 19:32 EDT

Investigating

We're currently observing increased error rates on Nlad/Nav transactions. As soon as we receive an update, we will pass it along.
Posted May 21, 2025 - 17:34 EDT
This incident affected: USAC - Vendor System (NLAD, National Verifier).