We're going to mark this incident as closed as most services impacted have been resolved according to Google. If there are further issues, please let us know.
Posted Jun 12, 2025 - 18:47 EDT
Monitoring
Google has confirmed they are seeing signs of recovery and have received confirmation from customers that the Google Cloud products are also seeing recovery in multiple regions. They expect the recovery to complete in less than an hour.
Posted Jun 12, 2025 - 17:25 EDT
Identified
Google is continuing to work towards a resolution. At this time, the Captcha issue appears to be intermittent, but other services may still be impacted. For example, we've heard reports that there are still issues on the USAC website. When redirected from the CGM application to the USAC website, users may see an error that says "There was a problem. Please come back later and try again. This is not a problem with your computer or the internet connection..." They may also see other misc errors on the website until the issue is fully resolved. Once we receive more info, we will pass it along.
Posted Jun 12, 2025 - 16:32 EDT
Investigating
We've received reports that Google's Captcha service is having issues. Google is aware of this issue and is looking into it further. This appears to be impacting users logging into the CGM Portal as well as USAC's systems. Until the issue is resolved, users may have issues signing into the portal or completing applications on the NLAD website. Once we receive additional information, we will pass it along.
Posted Jun 12, 2025 - 14:56 EDT
This incident affected: USAC - Vendor System (NLAD, National Verifier), CGM (Review Queue, Reporting Portal, ECP Web App), and Third Party Vendor Systems (Google ReCaptcha).